VULNERABILIDAD LINUX - REDHAT - CENTOS - DEBIAN

Nuevo Error En Núcleo De Linux Afecta A Distribuciones De Red Hat, CentOS Y Debian

Encuentra en el sitio

Últimos Artículos

Investigadores de seguridad publicaron detalles y los exploits de prueba de concepto (PoC) de una vulnerabilidad de desbordamiento de enteros en el kernel de Linux, el cual podría permitir que un usuario sin privilegios obtuviera acceso de superusuario al sistema “atacado”.

La vulnerabilidad, descubierta por el proveedor de soluciones de cumplimiento y seguridad basadas en la nube Qualys, el cual se ha denominado “Mutagen Astronomy“, afecta las versiones del kernel lanzadas entre julio de 2007 y julio de 2017, lo que afecta las distribuciones de Red Hat Enterprise Linux, CentOS y Debian.

La vulnerabilidad Mutagen Astronomy catalogada como CVE-2018-14634, es un tipo de problema de escalamiento de privilegios local -uno de los problemas más comunes con los sistemas operativos como un todo- y existe en la función create_elf_tables () del kernel de Linux que opera las tablas de memoria.

Para explotar con éxito esta vulnerabilidad, los atacantes deben tener acceso al sistema de destino y ejecutar su exploit que conduce a un desbordamiento de búfer, lo que resulta en la ejecución de código malicioso y logra un control completo del sistema afectado.

VULNERABILIDAD LINUX - REDHAT - CENTOS - DEBIAN

Según un aviso de seguridad publicado por Qualys el martes, la vulnerabilidad de seguridad se puede aprovechar para escalar los privilegios a la raíz a través de un binario SUID-root, pero solo funciona en sistemas de 64 bits.

“Este problema no afecta a los sistemas de 32 bits, ya que no tienen un espacio de direcciones lo suficientemente grande como para explotar este defecto. Es poco probable que los sistemas con menos de 32 GB de memoria se vean afectados por las demandas de memoria durante la explotación”, un aviso publicado por Red Hat lee.

“Solo se pueden explotar kernels con commit b6a2fea39318 (” mm: compatibilidad de argumento de longitud variable “desde el 19 de julio de 2007) pero sin confirmación da029c11e6b1 (” exec: Limitar arg stack a un máximo del 75% de _STK_LIM “desde el 7 de julio de 2017) “, dice el aviso de Qualys.

Se dice que las versiones de Linux Kernel 2.6.x, 3.10.xy 4.14.x son vulnerables a la falla de Mutagen Astronomy.

Si bien la mayoría de las distribuciones de Linux han respaldado commit da029c11e6b1 con sus núcleos soportados a largo plazo para solucionar el problema, Red Hat Enterprise Linux, CentOS y Debian 8 Jessie (la versión actual “antiguamente estable”) aún no se han implementado y, por lo tanto, todavía son vulnerables

Exploits Prueba de Concepto (PoC)

Qualys informó la vulnerabilidad a Red Hat el 31 de agosto de 2018 y a los desarrolladores de kernel de Linux el 18 de septiembre de 2018. Red Hat, asignó la falla como “importante” con una puntuación CVSS de 7.8 (gravedad alta), ha comenzado a lanzar actualizaciones de seguridad que abordan el problema

“Este problema afecta a la versión de los paquetes kernel como se entrega con Red Hat Enterprise Linux 6, 7 y Red Hat Enterprise MRG 2. Las futuras actualizaciones del núcleo para Red Hat Enterprise Linux 6, 7 y Red Hat Enterprise MRG 2 resolverán este problema”. Red Hat dice.

Sin embargo, las versiones de Linux kernel incluidas con Red Hat Enterprise Linux 5 no se ven afectadas por la vulnerabilidad Mutagen Astronomy. Los investigadores de Qualys también han publicado detalles técnicos y exploits de prueba de concepto (Exploit 1, Exploit 2) para la vulnerabilidad al público.

Resumen
Fecha Publicación
Resumen articulo
Investigadores de seguridad publicaron detalles y los exploits de prueba de concepto (PoC) de una vulnerabilidad de desbordamiento de enteros en el kernel de Linux, el cual podría permitir que un usuario sin privilegios obtuviera acceso de superusuario al sistema "atacado".
Calificación
51star1star1star1star1star
Etiquetas: ,

Deja un comentario